miércoles, mayo 14, 2008

Wireless Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01) en Ubuntu 8.04

En Ubuntu 8.04 he tenido problemas con la placa wireless del RE, cosas que con la 7.10 no.

La solución:

Verifica el modelo de tu placa con
$ lspci | grep Broadcom
la mia dice:

10:00.0 Network controller: Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)

Instala build-essential con
$ sudo aptitude install build-essential

$ sudo aptitude install b43-fwcutter

Después
$ wget http://downloads.openwrt.org/sources/broadcom-wl-4.80.53.0.tar.bz2
$ tar xvfj broadcom-wl-4.80.53.0.tar.bz2
$ cd broadcom-wl-4.80.53.0
$ cd kmod
$ sudo b43-fwcutter -w /lib/firmware wl_apsta.o
$ cd
$ wget http://linuxwireless.org/download/compat-wireless-2.6/compat-wireless-2.6.tar.bz2
$ tar xvfj compat-wireless-2.6.tar.bz2
$ cd compa-wireless-2.6
$ make
$ sudo make install
$ sudo make load

Con esto debería andar sin problemas. Y si todo sale bien, después de unos 30 segundos ya se deberan ver tus redes wireless desde el icono de Network Manager.

9 comentarios:

Juan dijo...

tengo un problema en este paso:
tar xvfj compat-wireless-2.6.tar.bz2

me sale:
tar: compat-wireless-2.6.tar.bz2: No se puede open: No existe el fichero ó directorio
tar: El error no es recuperable: salida ahora
tar: Child returned status 2
tar: Salida con error demorada desde errores anteriores

alguna ayuda?

insunzam dijo...

Buena.... me salvaste el dia. Llevo dias tratando de conectar la wifi

Ojo que el link a compat... baja un html. Al abrirlo con firefox sale el enlace para descargar el archivo bz
Saludos
Mario

Anónimo dijo...

Muchas gracias!!
Te pasaste loco, me has ayudado mucho.
Grande la comunidad linuxera, harto ayuda a los newbies.

gamerfear 2v dijo...

no manches bro muchisimas gracias ya lo habia intentado todo y nadamas no quedaba te debo una grande, que te valla chido i ojala nos podamos seguir ayudando

gamerfear 2v dijo...

o solo una cosa mas,el archivo no carga cuando reinicio el equipo no se que se pueda hacer, por ahora solo lo cargo cada vez que inicio

Anónimo dijo...

Muchas gracias mi hermano, funciono de maravillas.
Ahora ya puedo navegar en mi cama :)

Saludos

Anónimo dijo...

Ayuda... que puedo hacer

Me sale un problema en este paso:

$ make
make -C /lib/modules/2.6.24-17-generic/build M=/home/guaicamacuto/compat-wireless-2008-05-31 modules
make: *** /lib/modules/2.6.24-17-generic/build: No existe el fichero ó directorio. Alto.
make: *** [modules] Error 2

Eduardo Ortega dijo...

Ey!, muchas gracias Angel, muy útil el tutorial muchísimas gracias :)

Anónimo dijo...

alguien me podria ayudar me sale este error
/home/darklen/compat-wireless-2008-06-10/config.mk:30: "WARNING: You are running a kernel >= 2.6.23, you should enable CONFIG_NETDEVICES_MULTIQUEUE for 802.11n support"
make -C /lib/modules/2.6.24-16-generic/build M=/home/darklen/compat-wireless-2008-06-10 modules
make[1]: se ingresa al directorio `/usr/src/linux-headers-2.6.24-16-generic'
/home/darklen/compat-wireless-2008-06-10/config.mk:30: "WARNING: You are running a kernel >= 2.6.23, you should enable CONFIG_NETDEVICES_MULTIQUEUE for 802.11n support"